2009年03月

2009年04月・2009年03月・2009年02月

2009/03/30(月)

突然、奈良へ

JR奈良車で奈良へ。出張ではありません。残念ながら旅行でもありません。忌引。
次に来るのは旅行でだと思っていたのですが...
知らない間に新しい高速道路が開通していたり。以前あった店が無くなっていたり。
月日が経つのは早いもので。来年の平城遷都1300年祭に向けて整備も進んでいるようです。
ちなみにこのブログ記事は出かけ先で更新、出かけ先でもインターネットに繋げられればブログの更新もできたり。出来て当然なのですが、せっかくなのでつい試したくなる訳です。VPNを利用していた頃も懐かしい。インターネットVPNが利用できればセキュアに社内のサーバに繋いで必要な作業もできたり。急遽発生した休日対応とかは微妙でしたけど。
[ Google Maps API : JR奈良駅 ]


2009/03/27(金)

Cisco851 内部サーバを公開する場合

前回のCisco851 グローバルIPをDHCPで自動取得する場合に続いて
自宅サーバ等を外部に公開する場合。Cisco ASAとIOSがごっちゃになってど忘れ、設定方法を思い出すのに時間を取られてしまった。という訳でこれも備忘録程度に掲載しておきます。

公開するサーバのIPアドレス:192.168.1.20
公開(ポート変換)するポート:tcp 80(Webサーバ)
前回の設定に下記設定を追加。

ip nat inside source static tcp 192.168.1.20 80 interface FastEthernet4 80

いわゆるスタティックNATってやつです。デバッグはdebug ip natコマンドで、NAT変換テーブルを確認する場合はshow ip nat translationsコマンドで。
グローバルIPアドレスが固定である場合はinterface FastEthernet4をIPアドレスに書き変えて下さい。本例の様にグローバルIPアドレスが固定で無い場合はDynamicDNSのサービス等を利用する必要あり。
この設定でルータ宛(Fa4)に届いたWebサーバへのアクセス要求がサーバへ転送されます。
ポート番号を変えれば色々と応用は可能。法人等で24時間稼動にする場合はセキュリティを考えDMZを一応は用意すべき。


2009/03/25(水)

Perfume「ワンルーム・ディスコ」 & MAKAI「LEGEND」

最近、ブログネタが豊富。
Perfumeのみならず中田ヤスタカ氏の知名度も高くなったようで。とりあえず、25日発売のワンルーム・ディスコを取り上げておきます。個人的な感想は前作の評価+αといった感じかなー。
それからMAKAI氏も同日アルバムCDを発売。こちらは名曲の洋楽カバーアルバム。今回の作品も車でドライブの時等に最適な感じ。個人的にはI Believe In Miracle feat. LISAとDreamin' feat. 日之内エミが良い感じかな。このブログのトップページ右で紹介している曲が良いと思う人にオススメです。


2009/03/22(日)

RedRails、Ruby on Rails 統合開発環境

RedRailsRedRails
Android携帯の日本発売が何時になるのか分からないのでAndroidは当分放置かも。代わりにRuby on Railsの開発環境を復活させてみました。以前利用していた開発環境は削除してしまったので、EclipseプラグインのRed RailsをインストールしてWindows Vista上に復活。
1年以上前にもRuby on Railsほったらかしとブログに掲載していたり。
非常に簡単にRuby on Rialsが利用できるInstant Rails。しかしInstant Railsに含まれるウェブサーバのApacheが起動せず。他のプログラムがPortを使用中だとか。Ruby on Railsは一般にMongrelというWebサーバを利用するのでプログラムを行う上では問題が無いといえば問題ないのですが。Apacheが必要とするPortは基本80番。市販されているウイルス対策ソフトが入っているにも関わらず、不正進入されて勝手にWebサーバ化されたのかと一瞬焦りました。が、netstatコマンド等々で確認した所、使用しているプログラムは無し。Apache.exeを直接実行すれば何の事はなく普通にApacheが起動しました。どうもWindows Vistaが原因の可能性が高そうです。開発環境も今の所はまだWindows XPの方が良いと言う所でしょう。
ApacheはMySQLデータベースを管理する上でMySQLAdminを利用する為に用意されているようです。
しかし、開発環境を復活はさせたものの実験だけではつまらないし、作ろうと思うアプリケーションが思い浮かばない。レンタルサーバを利用するのであればPHPの方が便利だし、Ruby on Railsだけの為に自宅サーバを24時間稼動にして外部に公開するのも微妙。なんだかなぁ。


2009/03/21(土)

Cisco851 グローバルIPをDHCPで自動取得する場合

Cisco851Cisco Systemsのルータを利用してインターネットに接続する場合、NTT系光ファイバー等であればPPPoEによる接続が一般的ですが、YahooBBのADSLやCATV系等、グローバルIPアドレスをDHCPで自動取得する場合も。
法人での利用であれば固定IPか少なくともPPPoEである事が殆どだと思いますが一般家庭で使用する場合はDHCPによる取得って事もあったり。
Ciscoルータ自体が法人向けでもある為、DHCPによるグローバルIPアドレスの自動取得についての情報はなかなかないようで。
備忘録程度に掲載しておきます。

interface FastEthernet4
ip address dhcp client-id FastEthernet4
ip nat outside

interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside

ip route 0.0.0.0 0.0.0.0 FastEthernet4

ip dns server
ip nat inside source 1 interface FastEthernet4 overload

access-list 1 permit 192.168.1.0 0.0.0.255

上記設定はCisco851のWANポートがFa4なので他の機種の場合は、該当WANポートに読み変えて下さい。ルータのローカルIPが192.168.1.1、クライアントPCのIPが192.168.1.2~254と仮定。
access-listは必要最低限の記述、使用可能ポートや使用可能プロトコル等細かく設定すべき。
ip address dhcp client-id FastEthernet4 コマンドでDHCPによるグローバルIP取得
ip dns server コマンドでdnsサーバ機能を使用
上記設定であれば各PCにスタティックにIPアドレスを設定する場合はIPアドレスを192.168.1.2~254サブネットマスクを255.255.255.0 デフォルトゲートウェイとDNSサーバを192.168.1.1とすれば問題ないハズ。もちろんクライアントPC側もDHCPが利用できるようにしても良いとは思いますが。
モデムを他のルータに繋いでいた場合は、モデムの電源を一度落とす必要があるかも。
ついでに、購入後ほったらかしだったIOSのアップグレードも行っておきました。124-6.T11→124-15.T8


2009/03/19(木)

宅建登録実務者講習の申込み

宅地建物取引主任者となるには2年の実務経験が必要なります。宅地建物取引主任者資格試験の合格者はあくまで宅地建物取引主任者資格試験合格者。
管理業務主任者ではあったものの宅地建物取引主任者ではなく。不動産を直接取引する部門に配属していた期間はなかった為、宅地建物取引の実務経験換算は0年。その必要な2年の実務経験の代わりとなるのが宅建登録実務者講習。
今年の早期申し込みの締め切りが20日まで。会社が推奨しているそうなので悩んだ結果、実務経験なく主任者登録ができるよう宅建登録実務者講習に申し込みをしました。今月末頃から通信教育。5月のゴールデンウィーク頃に2日間のスクーリング。
合格からかなり年数が経つので、なんだかなー。
宅建登録実務者講習、いつの間にか公的機関でなく民間の専門学校でも実施するようになっていたり。受講料も確か4万円近くしたはず。それが早期申し込みで2万6千円とか。
主任者登録費用は相変わらずのようですが。
何にしても自由時間にやる事がこれまた増えたな~。


2009/03/15(日)

鶴見神社・曹洞宗大本山總持寺

鶴見神社鶴見神社曹洞宗大本山總持寺
鶴見神社と曹洞宗大本山總持寺へ行ってきました。
鶴見神社、思ったよりこぢんまりしてましたが、昔は杉山大明神(杉山神社)と称されていたそうで創建は推古天皇の時代。かなり歴史があるようです。
曹洞宗大本山總持寺は、敷地がかなり広大。大本山というだけあります。
總持寺の歴史を簡単にまとめると・・・奈良時代、行基によって能登国(石川県)に、諸嶽寺として創建されたのが始まり。平安時代は真言律宗曹洞宗瑩山紹瑾が總持寺と改名。 明治時代に火災で焼失、神奈川県、鶴見の地に移転。ということらしい。移転からもうすぐ100年。
行基は東大寺大仏造立に関わった事で有名ですが、色々な所に寺を創建したようで。又、お寺の宗派ってのは時代によって又は住職によって結構変わるものなのでしょうか?
平安時代は信言律宗、瑩山紹瑾は天台宗を学んだものの最終的に曹洞宗?よくわかりません。


2009/03/14(土)

スターバックスコーヒー 株主優待 2008年分

スターバックスコーヒー 株主優待 2008風邪が完治せず。回復→悪化→回復を繰り返している感じ。既に1週間が経ちます。頭がぼけーっとして若干ふらふら。
遠出はもちろん、パソコンで色々と作業する気も欠如気味なので、使用期限が今月までだったスターバックスの株主優待券を使いに行ってきました。無料券、せっかくなので一番大きいVentiサイズで頼んでみたり。ちなみにVentiサイズを注文する人って1日にどれぐらいいるんだろう。
ついでに夕飯用にゼンショーの株主優待を使いにすき家まで。
今日の夕飯はコーヒー+カレー。微妙な組み合わせ。だめだ、思考能力が落ちてる。
この頭がぼけーっとするのだけは何とかならないものか。思考能力が通常時の30%~40%。


2009/03/13(金)

Android。イギリスでも有料アプリ解禁

Android。アメリカに続いてUK(United Kingdom)での有料アプリケーション公開が解禁されたそうで。一方、日本でもAndroidを組み込み機器向けに使用しようという推進団体の発足などニュースが無い訳ではないのですが、Android携帯の発売すら時間がかかりそうなのでAndroidはしばらく放置しようかと迷っていたり。
ちなみに以前、カーナビ等で利用する共通OSを採択しては的なコメントを掲載したりもしましたが、Androidをカーナビ共通OSとして使用するのはどうなんだろう。現在所有しているAndroid携帯でも電源OFFの状態から起動するまで予想以上に時間がかかるので、機器を性能の高いものにするかAndroidOS自体の改良が必要な気がします。起動に時間のかかるカーナビじゃ微妙ですからねぇ。
家電に組込む以上、携帯電話の様に使っていなくとも低消費電力で常に待機状態ってのもエコに反すると思いますし。
しかし、予想通りすぎる展開~。IT分野のアナリストにでもなれそう?
AndroidをIP電話やテレビに使う


2009/03/07(土)

アミューズ 株式分割 2003年以来 x1.2

風邪をひいたせいで掲載が遅くなりましたが・・・数日前
アミューズから正式に手紙で「株式の分割に関する取締役会決議ご通知」が届きました。
平成21年4月1日付けをもって普通株式1株を1.2株に分割。業績も良いようで、通常であれば今後の株価の動きに注目と言いたい所ですが、不景気な昨今、アメリカの株価に大きく左右される状況でどう動くかは予想できません。というか既に値上がり終了?動かないのが得策?
って似非証券アナリストみたいでなんとなく嫌なコメント。資金難な私。動きようがありません。
それから、次回株主総会の内容が決まったようで。
アミューズが株主参加の新人発掘全国オーディション開催
株式分割は2003年以来。「1株につき1.2株の割合をもって分割する。ただし、分割の結果生ずる1株未満の端数株式は、これを一括売却または買受し・・・」とありますが、1株未満であって単元(アミューズの場合は100株)未満株買受ではないですよねぇ。単元未満株買受と勘違いしている人もいるようですが・・・。
なにはともあれ、昨今の不景気で全体的に日本の株価は下げ傾向、長期保有していてもただ株価が下がるだけの会社が多い中、株主を楽しませてくれる良い会社です。


2009/03/06(金)

情報セキュリティガバナンスシンポジウム2009

仕事に関連するネタは極力掲載しないようにしているのですが、公開講演ネタなので。
会社指示の下、経済産業省と日本経済新聞社が主催する情報セキュリティガバナンスシンポジウム2009の講演を聞きに東京ビッグサイトまで行ってきました。こういった講演を聞きに行かせてもらえるというのは非常に有難い。フィードバックもしっかりせねばと。
しかし、こういう時に限って前日から風邪。仕事から帰って体の節々が痛いので体温計で計測してみると、38度9分の熱。体温計を見てさらにダメージを受けた感じ。朝起きて若干回復していたのと、事前申し込み制という事もあったので若干無理して行って来ました。体がだるいだけで幸い咳がほとんど出なかったというのが助かった所。咳が出なければ遅めのインフルエンザという事もないでしょう。
こういうのに参加するのはかなり久しぶり、このレベルの講演を直接聞けるのは関東圏の特権かなとも思ったり。地方から出張でわざわざというわけにはなかなか行かないでしょう。
特別講演やパネル討論については講演を仕事としている方の講演というわけではないので比べるのがどうかとも思いますが、やはり良かったと思ったのは、基調講演だった内閣官房情報セキュリティセンター 情報セキュリティ補佐官の講演。
一方、特別講演やパネル討論前の各社セキュリティ対策についての説明を聞いて思ったのが、数年前とあるIT企業で導入を進めていた"あれ"(名称等の掲載は避けておきます)。そのIT企業の考え、方向性は正しかったわけで。未だ究極は"あれ"か"あれ"の導入なんだなと改めて思ったわけで。他社製品の宣伝になってしまうからか、これら講演に出るクラスの企業の話に出てこなかったのが逆に気になってしまったり。そう考えると"あれ"はどちらも未だコストパフォーマンス、融通、出来の部分に問題があるのかなとも。また改めて、今まで色々な経験をしてきたものだとふと過去を振り返ったり。
ちなみに、情報セキュリティ補佐官は奈良先端科学技術大学院大学の教授でもあるそうで、非常に馴染みのある場所にある大学院大学だったりします。大学卒業後こういう大学院を経てってのもありだったかも・・・って高校で文型を選び大学も文型卒な時点でかなりムリ。


Blog

CCNA(Cisco Certified Network Associate)取得を目指している取得した取得後有効期限満了したぎりぎり20代30代突入30代30代後半40代突入管理人のブログです。

Google Maps API

googlemap.jpg
地図 ブログ

 

Twitter

旧サイト

旧サイト

Recent Entries

Amazon Alexa Skill Awards ファイナルステージイベント
ユニバーサル・スタジオ・ジャパン
金峯山寺
吉野神宮
Perfume「Future Pop」
Maker Faire Tokyo 2018に出展してきた
株式会社アミューズ 第40期定時株主総会
Essential Phone PH-1
出流山 満願寺
筑波山 筑波山神社

Monthly Archives

2018年09月
2018年08月
2018年06月
2018年05月
2018年04月
2018年03月
2018年02月
2018年01月
2017年12月
2017年11月
2017年10月
2017年09月
2017年08月
2017年07月
2017年06月
2017年05月
2017年04月
2017年03月
2017年02月
2017年01月
2016年12月
2016年11月
2016年09月
2016年08月
2016年07月
2016年06月
2016年05月
2016年04月
2016年03月
2016年02月
2016年01月
2015年12月
2015年11月
2015年10月
2015年09月
2015年08月
2015年07月
2015年06月
2015年05月
2015年04月
2015年02月
2015年01月
2014年12月
2014年11月
2014年10月
2014年09月
2014年08月
2014年07月
2014年06月
2014年05月
2014年04月
2014年03月
2014年02月
2014年01月
2013年12月
2013年11月
2013年10月
2013年09月
2013年08月
2013年07月
2013年06月
2013年05月
2013年04月
2013年03月
2013年02月
2013年01月
2012年12月
2012年11月
2012年10月
2012年09月
2012年08月
2012年07月
2012年06月
2012年05月
2012年04月
2012年03月
2012年02月
2012年01月
2011年12月
2011年11月
2011年10月
2011年09月
2011年08月
2011年07月
2011年06月
2011年05月
2011年04月
2011年03月
2011年02月
2011年01月
2010年12月
2010年11月
2010年10月
2010年09月
2010年08月
2010年07月
2010年06月
2010年05月
2010年04月
2010年03月
2010年02月
2010年01月
2009年12月
2009年11月
2009年10月
2009年09月
2009年08月
2009年07月
2009年06月
2009年05月
2009年04月
2009年03月
2009年02月
2009年01月
2008年12月
2008年11月
2008年10月
2008年09月
2008年07月
2008年06月
2008年05月
2008年04月
2008年03月
2008年02月
2008年01月
2007年12月
2007年11月
2007年10月
2007年09月
2007年08月
2007年07月
2007年06月
2007年05月
2007年04月
2007年03月
2007年02月
2007年01月
2006年12月
2006年11月
2006年10月
2006年09月
2006年08月
2006年07月
2006年06月
2006年05月
2006年04月
2006年03月
2006年02月
2006年01月
2005年12月
2005年11月
2005年10月